Reply by September 17, 20032003-09-17
I'm having a very odd problem... Quartus II (2.2) has started ignoring
.mif file changes on me when doing "smart compile", which requires me
to sit for 20 minutes and recompile the whole design for a simple
memory change.

The really weird part is that this is new behaviour -- I have one
project on which this works beautifully and it was a major assistance
debugging that design, but on a different (somewhat larger) project,
it doesn't work at all -- Quartus seems to just ignore the .mif file
changes and happily produces bitstream files with all the old memory

Is there a hidden option somewhere?  I have added all the .mif files as
project files; it doesn't seem to affect this behaviour.


P.S. Upgrading to Quartus 3.0 is not an option due to the changes in
platform requirements.

<> at work, <> in private!
If you send me mail in HTML format I will assume it's spam.
"Unix gives you enough rope to shoot yourself in the foot."
Architectures needed: ia64 m68k mips64 ppc ppc64 s390 s390x sh v850 x86-64