Forums

EPC16 will not Flash Program

Started by Steven October 13, 2003
I have a design with a JTAG chain consisting of APEXII, EPC16UC88,
MERCURY, EPC16UC88.

I have built the design 3 previous times and been able to program my
boards, no problems.

Now I have 3 boards, one works fine, one will not accept a .POF file
into the second EPC16 part, and the third will not accept a .POF into
either of the EPC16 parts.

What happens is Quartus starts erasing the part and after about 45
seconds kicks out with an error "Error Operation Failed"

I would think I have a bad part, but that would mean I have 3 bad
parts out of six (and they are ball grids so not easy to swap out).

I think the JTAG chain is OK, I can do .SOF programs and everything
works great.

Any ideas on what else to check or try, or could I have a batch of bad
parts????

I have tried this under Quartus 2.8 and 3.0.  I have also tried using
a jam file under MaxPlus 10.2.  I have tried it with different length
cables from my parallel port, I have tried it with different Byte
Blasters, and on different computers.



Thanks
Hi I had the same with an EPC2.  Take a closer look to the routing of the
TDO-Line. This line has no pullup or -down resitor. So this was my problem.
The TDO-line was to close and to long by an other clock line.

i hope it helps.

Thomas

"Steven" <sleischo@scires.com> schrieb im Newsbeitrag
news:c3cc9b26.0310130613.6f053388@posting.google.com...
> I have a design with a JTAG chain consisting of APEXII, EPC16UC88, > MERCURY, EPC16UC88. > > I have built the design 3 previous times and been able to program my > boards, no problems. > > Now I have 3 boards, one works fine, one will not accept a .POF file > into the second EPC16 part, and the third will not accept a .POF into > either of the EPC16 parts. > > What happens is Quartus starts erasing the part and after about 45 > seconds kicks out with an error "Error Operation Failed" > > I would think I have a bad part, but that would mean I have 3 bad > parts out of six (and they are ball grids so not easy to swap out). > > I think the JTAG chain is OK, I can do .SOF programs and everything > works great. > > Any ideas on what else to check or try, or could I have a batch of bad > parts???? > > I have tried this under Quartus 2.8 and 3.0. I have also tried using > a jam file under MaxPlus 10.2. I have tried it with different length > cables from my parallel port, I have tried it with different Byte > Blasters, and on different computers. > > > > Thanks