Forums

Quartus doesn't work with Pentium Hypertheading!

Started by SDL January 23, 2004
Hi,
I have compiled with Quartus II 3.0 SP2s a project that fills a Cyclone C12
for 89%.
Quartus ends  the work later around 2.30 hours (Pentium 4 - 2.8Ghz).
If I try to compile the same project on a PC with processor Intel Pentium 4
with  Hypertheading technology, Quartus doesn't succeed in ending the
fitting, after 24 hours it is I still stop to the 80%.
In the same PC I succeed in quickly compiling less binding projects for the
fitting.

Is there someone other of you that has had the same problem?

Does a way exist for resolving this? I have tried to disable from the PC
BIOS, the Hypertheading, also this doesn't resolve the problem .

Salvo


"SDL" <S.DeLuca_No_Spam@USA.NET> wrote in message news:<xx5Qb.6304444$Id.1022160@news.easynews.com>...
> Hi, > I have compiled with Quartus II 3.0 SP2s a project that fills a Cyclone C12 > for 89%. > Quartus ends the work later around 2.30 hours (Pentium 4 - 2.8Ghz). > If I try to compile the same project on a PC with processor Intel Pentium 4 > with Hypertheading technology, Quartus doesn't succeed in ending the > fitting, after 24 hours it is I still stop to the 80%. > In the same PC I succeed in quickly compiling less binding projects for the > fitting. > > Is there someone other of you that has had the same problem? > > Does a way exist for resolving this? I have tried to disable from the PC > BIOS, the Hypertheading, also this doesn't resolve the problem . > > Salvo
Hi Salvo, The Quartus compiler applications do not make use of hyperthreading. The compiler executables (quartus_map, quartus_fit, quartus_tan, quartus_asm) are all single threaded applications. Based on our experiments the absence or presence of hyperthreading has not had an effect on Quartus compile times or results. One way to eliminate if the problem you are seeing is being caused by hyperthtrading is to run the compiler executables in command line mode. If I have a design called stor and the compiler action point name is stor_flex10k the instructions to compile would be as follows from the DOS command prompt: quartus_map --import_settings_files=on --export_settings_files=off stor -c stor_flex10k quartus_fit --import_settings_files=off --export_settings_files=off stor -c stor_flex10k quartus_asm --import_settings_files=off --export_settings_files=off stor -c stor_flex10k quartus_tan --import_settings_files=off --export_settings_files=off stor -c stor_flex10k --timing_analysis_only quartus_eda --import_settings_files=off --export_settings_files=off stor -c stor_flex10k According to your description there were two different PC's used, one a Pentium 4 2.8 Ghz and the other a Pentium 4 with hyperthtrading. Do they have the same amount of RAM? If you can do send me your machine specs and email me the qar file, and the specs of the computer which is taking a long time to compile. We would definitely like to investigate this further. Thanks - Subroto Datta Altera Corp.
> Does a way exist for resolving this? I have tried to disable from the PC > BIOS, the Hypertheading, also this doesn't resolve the problem .
The hyper-threading "problem" is a red herring -- once you disable hyper-threading in the BIOS, your machine will not use any hyper-threading functionality and is in effect just a normal P4 processor. There must be some other problem with your compile -- see Subroto's post. Regards, Paul Leventis Altera Corp.