Problem with Xilinx 9.2i and Modelsim 6.0

Started by Anonymous in comp.arch.fpga9 years ago 1 reply

Hi, I`m trying to make a temporal simulation ( Post place & route model ) of a FPGA designed in Xilinx 9.2i in Modelsim 6.0, but the Modelsim...

Hi, I`m trying to make a temporal simulation ( Post place & route model ) of a FPGA designed in Xilinx 9.2i in Modelsim 6.0, but the Modelsim gives me an error of type Error - (vsim 3193), refered from a library called swifpli_mti.dll wich Modelsim doesn=B4t find. I can't get other Modelsim, and I was looking in the modelsim.ini file, changing any command that I found in Internet. This chan...


Problem of uninstall modelsim

Started by fl in comp.arch.fpga11 years ago 1 reply

Hi, I have installed Xilinx webpack and modelsim in my computer. I find it is rather perhaps because of the memory not large enough. The...

Hi, I have installed Xilinx webpack and modelsim in my computer. I find it is rather perhaps because of the memory not large enough. The webpack still searches for modelsim for simulation even I uninstalled it (modelsim). I even tried uninstalled webpack and reinstalled it. It still looks for modelsim (of course, I have set the option back in the dialog box of simulator). Could you tell me ...


problem with Modelsim 5.8 Xilinx Edition

Started by kcl in comp.arch.fpga13 years ago 5 replies

Hi when i launch ModelSim 5.8c XE, the windows with the logo of modelsim( a rhinoceros) open and after a few seconds it close and nothing...

Hi when i launch ModelSim 5.8c XE, the windows with the logo of modelsim( a rhinoceros) open and after a few seconds it close and nothing else happen there no process of modelsim running in the process list of winXP I don't understand because last week It always run correctly. I tried to reinstall Modelsim and it don't change Does anyone know this problem?? Thank you Alexis ...


Detecting if an error happened in ModelSim

Started by Chris Maryan in comp.arch.fpga10 years ago 8 replies

Is there a way to detect if an error or warning occured during a simulation run in ModelSim scripting. I'm just trying something simple: what...

Is there a way to detect if an error or warning occured during a simulation run in ModelSim scripting. I'm just trying something simple: what I'd like to do is have my test bench simulation set up script quit modelsim if there are no errors, or stop and leave modelsim running if an error occurs so I can look at the waveform trace (I'm launching modelsim automatically from Quartus). Any tho...


Xilinx ISE 6.1i+SP2 And Modelsim 5.8

Started by Peng Cong in comp.arch.fpga14 years ago 1 reply

Hi all I have a problem with Modelsim simulation. When I use Modelsim 5.7f, I creat a project under ISE 6.1i+SP2, set Simulator value...

Hi all I have a problem with Modelsim simulation. When I use Modelsim 5.7f, I creat a project under ISE 6.1i+SP2, set Simulator value to Modelsim, it's fine. But yesterday after I upgrade Modelsim to version 5.8, when I open the project, it said that "This project was last saved with the project property 'Simulator' set an unvalid value of 'Modelsim'". How can I solve this prob...


Modelsim GTP_DUAL not recognized

Started by Ruzica in comp.arch.fpga9 years ago 5 replies

Hello all, I am using Modelsim 6.3 and ISE 10.1 and have a gtp_dual in my design. When I try to simulate it, Modelsim reports the...

Hello all, I am using Modelsim 6.3 and ISE 10.1 and have a gtp_dual in my design. When I try to simulate it, Modelsim reports the following error: (vcom-1141) Identifier "gtp_dual" does not identify a component declaration. I have all the libraries with smartmodels installed in Modelsim, in fact I can see the component gtp_dual in Unisim and Simprim libraries in Modelsim workspac...


EDK does not find Modelsim

Started by Timo Gerber in comp.arch.fpga10 years ago 1 reply

Hi, I want to launch Modelsim from within Xilinx EDK. I have the correct versions installed, the ISE recognizes Modelsim correctly. EDK says...

Hi, I want to launch Modelsim from within Xilinx EDK. I have the correct versions installed, the ISE recognizes Modelsim correctly. EDK says it cannot find Modelsim, although i have set the following variables in Win XP: %MODELSIM% points to the correct modelsim.ini %MODELTECH% points to the win32 Folder of the installation package %MODEL_TECH% also points to the win32 folder. What is...


ModelSim Licence problem

Started by Sonali in comp.arch.fpga12 years ago 2 replies

I am using xilinx Tool Ver 6.3. And Modelsim 5.8. Due to some reasons I uninstalled modelsim. After I installed it again I faced a problem...

I am using xilinx Tool Ver 6.3. And Modelsim 5.8. Due to some reasons I uninstalled modelsim. After I installed it again I faced a problem related to license . ModelSim is installed. and While running it asks for license. At licensing Wizard of ModelSim, I choose a license file which was there previously( we kept a copy of license file before uninstalling). but gives following error m...


modelsim

Started by fazulu deen in comp.arch.fpga10 years ago 5 replies

Hai all, Can any one suggest with an example how to run c++ code in modelsim simulator...I didnt understand the example mentioned in modelsim...

Hai all, Can any one suggest with an example how to run c++ code in modelsim simulator...I didnt understand the example mentioned in modelsim user guide..Anyone tried this?? regards, fazal


ModelSim License Problem

Started by Sonali in comp.arch.fpga12 years ago

I am using xilinx Tool Ver 6.3. And Modelsim 5.8. Due to some reasons I uninstalled modelsim. After I installed it again I faced a problem...

I am using xilinx Tool Ver 6.3. And Modelsim 5.8. Due to some reasons I uninstalled modelsim. After I installed it again I faced a problem related to license . ModelSim is installed. and While running it asks for license. At licensing Wizard of ModelSim, I choose a license file which was there previously( we kept a copy of license file before uninstalling). but gives following error...


ModelSim Designer

Started by RobJ in comp.arch.fpga12 years ago 10 replies

Anyone using this tool from Mentor? If so, any comments about it would be much appreciated. And any comments on how ModelSim + ModelSim Designer...

Anyone using this tool from Mentor? If so, any comments about it would be much appreciated. And any comments on how ModelSim + ModelSim Designer compares to Aldec's Active-HDL environment would be even better. I currently own ModelSim but am looking for a more complete environment (testbench automation, graphical tools, code coverage, etc.). Thanks, Rob


view memory contents in modelsim

Started by hariz in comp.arch.fpga8 years ago 3 replies

i am just a new user of modelsim and debussy, can anyone help me transfer my code to modelsim and debussy from quartus? i have a code in...

i am just a new user of modelsim and debussy, can anyone help me transfer my code to modelsim and debussy from quartus? i have a code in verilog using quartus..but due to long simulation time i can't view all the output..so i switched to modelsim..however, i cant view the memory contents in modelsim.. how can i double check the contents of my memory in modelsim?


signals in modelsim

Started by in comp.arch.fpga13 years ago 10 replies

Hi, how can I add internal signals to the wave output of modelsim? At the moment I have to add all the debug sinals to the port of my main...

Hi, how can I add internal signals to the wave output of modelsim? At the moment I have to add all the debug sinals to the port of my main entity. Another question is, if its possible to save the modelsim settings somehow? (wave repesentation as integer, scale, etc...) Do I have to close Modelsim everytime I resynthesize my uut? regards, Benjamin


Please help me!!!!! ModelSim question...

Started by Simone Winkler in comp.arch.fpga14 years ago 1 reply

Hello! I am a newbie trying to perform a simulation with ModelSim... I did a (very small) project with the Xilinx downloadable webpack - and...

Hello! I am a newbie trying to perform a simulation with ModelSim... I did a (very small) project with the Xilinx downloadable webpack - and as i wanted to simulate it with modelsim, modelsim closed after the following line: #vsim -lib work -t 1ps -L xilinxcorelib testbench the transcript file shows the following: # Reading D:/Programme/Modeltech_5.5d/win32/../tcl/vsim/pref.tcl m...


Modelsim Altera - Strange issue.

Started by LC in comp.arch.fpga7 years ago 1 reply

Hello, On a design I'm working Modelsim (Altera edition) doesn't like that I reset the simulation to rerun again. (for example I change the...

Hello, On a design I'm working Modelsim (Altera edition) doesn't like that I reset the simulation to rerun again. (for example I change the run length and restart the simulation again) it reports. # ** Error: (vsim-3170) Could not find 'D:\..myworkingpath...\simulation\modelsim\rtl_work.tb_port'. and I did not anything whatsoever outside modelsim to make the file disapear !!! an...


Modelsim library problem

Started by Denis Gleeson in comp.arch.fpga13 years ago 1 reply

Hello Im using Modelsim XE 5.5e for simulation. All was going well until I attempted to include delay information in my simulation by...

Hello Im using Modelsim XE 5.5e for simulation. All was going well until I attempted to include delay information in my simulation by bringing the .sdf from my synthesis tool. Now I just get # ** Fatal: ERROR: SDF files require Xilinx primitive library Now in the Load Design dialog box of Modelsim in the Libraries tab I have added all 4 libraries supplied with the modelsim package si...


How to get lowest price for a ModelSim license?

Started by Weng Tianxiang in comp.arch.fpga11 years ago 25 replies

Hi, We want to buy a ModelSim license. 1. Buy Xilinx-ModelSim version license from Xilinx website shop for $1150 with dongle and 1 year...

Hi, We want to buy a ModelSim license. 1. Buy Xilinx-ModelSim version license from Xilinx website shop for $1150 with dongle and 1 year expiration limit; 2. Buy ModelSim PE version from one of agents we contact: $3K for perpatual license. Both versions will work and make no differences to our applications. Does anyone knows a better way to buy a ModelSim license with lowest price e...


ISE 7.1 & ModelSim - Simulating Internal Signals

Started by Brendan Illingworth in comp.arch.fpga12 years ago 8 replies

Hi All, I am using Xilinx ISE 7.1 and ModelSim XE III 6.0 to analze flip-flop and routing behavior in a Virtex II part. Ports that are...

Hi All, I am using Xilinx ISE 7.1 and ModelSim XE III 6.0 to analze flip-flop and routing behavior in a Virtex II part. Ports that are declared in my VHDL entity declaration are simulated and shown in the wave window in ModelSim. My question is this; how does one specify in Xilinx ISE additional signals (that are not routed to IOB's) to be simulated in ModelSim? Using the "add probe" fea...


Modelsim PE vs. Aldec Active-HDL (PE)

Started by Pete Fraser in comp.arch.fpga8 years ago 41 replies

I've finally decided to buy a better simulator (I've been making do with Modelsim XE so far). Any thoughts as to the relative merits of...

I've finally decided to buy a better simulator (I've been making do with Modelsim XE so far). Any thoughts as to the relative merits of Modelsim PE and Active-HDL (PE) for FPGA simulation? Thanks Pete


Tcl used in Modelsim?

Started by Davy in comp.arch.fpga12 years ago 1 reply

Hi all, I am new to Modelsim and always use GUI to do all the work. I heard that we can use Tcl to control Modelsim to compile and run...

Hi all, I am new to Modelsim and always use GUI to do all the work. I heard that we can use Tcl to control Modelsim to compile and run a batch of work, is there any example available? BTW, I use Verilog. Any suggestions will be appreciated! Davy